Errors after upgrading Arch Linux

Today I got an error after upgrading my Arch Linux boxes. But it could be fixed within a few minutes.

While upgrading the system with yaourt the error messages shown in the example below occured.

$ yaourt -Syua
...
package-query: error while loading shared libraries: libalpm.so.10: cannot open shared object file: No such file or directory
package-query: error while loading shared libraries: libalpm.so.10: cannot open shared object file: No such file or directory
package-query: error while loading shared libraries: libalpm.so.10: cannot open shared object file: No such file or directory

To fix this issue the package-query package has to be rebuild and reinstalled like in the example below.

$ curl -O https://aur.archlinux.org/cgit/aur.git/snapshot/package-query.tar.gz
$ tar -xvf package-query.tar.gz 
$ cd package-query 
$ makepkg -si

If the installation was successfull the error message should be gone.

Links

Related articles